Can't get trace to work logically

  • Methodology :

    1. Open document. Import black silhouette png file
    2. Click on image (so I can drag around and see handles)
    3. select 'thin outlines' and 'black and white' as the options.
    4. click trace
    5. nothing happens

    click on 'extract fills' and it does work.. so if I select 'undo' the screen displays 'undo image trace'
    the nodes is populated. The .png has obviously been 'converted' to a vector graphic (i.e. the edges are now 'crisp' and not demonstrating the telltale blurring of a png.

    I can't edit the shape
    It is not on a seperate layer to the PNG
    I can no longer select the png
    Fill and stroke are both blank
    I can't export the file/shape
    It's annoying .. It's done what I wanted but I can't use the output - or separate from the original file..

  • Here's the source file I am trying with
    ultimately what I am trying to do is export an .svg / .ai file of a 1pt stroke outline of the attached

  • @ambros

    • Select the bitmap image;
    • Click the 'Trace' button, then…
    • Click 'Expand', then…
    • Select 'Ungroup All' from the Object menu…

    …and you have the generated vector object(s).

    Quick video here:

    The buttons in the 'Image Trace' panel have tooltips that explain what each of them does.

  • Thanks for replying so quickly
    After tracing / expanding / ungrouping
    selecting and delating.. i have go to this,.
    I still can't seem to select the outline and select 'fill' or adjust the stroke or anything though ?
    I just want to get it to a usable path !?
    ![0_1637846428328_Screenshot 2021-11-25 131836.jpg](Uploading 100%)

  • sorry i am getting a 'image file too big' error trying to upload a 58kb image file 2021-11-25 131836.png?dl=0

  • Thank you ! that last video was really helpful.
    I hadn;t realised how sensitive it was to were one clicks with the mouse..
    You're right it works perfectly.. I just needed to click in a different place on the graphic (if I click on his forehead it doesn't work.. if I click on his ear it does !!) .. i.e. you have to click exactly on the edge and then it works

    Thank you for such a quick reply and resolution.

  • @ambros Because the image has a thin white contour, tracing it with the default settings will result it two objects — a black shape and a separate gray contour.

    So I guess you deleted the black shape and then tried to change the fill of the gray contour instead of deleting the contour shape and using the black filled shape.

  • administrators

    @ambros Essentially @b77 explained all:

    It is important to remember, that the trace is "live", linked to the image and can be updated (retraced).
    It has to be expanded and ungrouped to have the vectors.

    Here is what I get with tracing:

    These are the settings I used:


    Also: the forum file size issues are still persisting.

  • Yes, thanks both @b77 @vectoradmin . I got there in the end.. although I am not sure what you mean about the thin white contour - i didn't see that on mine I don't think ?

  • administrators

    @ambros One option that might also be useful:
    If you do not need the "live" feature of the trace, then uncheck the "Keep with Image" in the Trace panel menu.
    In this case, there will be no need for expand, but an ungroup is still needed to get to the resulting curves.

  • @ambros said in Can't get trace to work logically:

    I am not sure what you mean about the thin white contour - i didn't see that on mine I don't think?

    The white background of the image was cleared in such a way that there is still a thin white contour around the black drawing.

    If you view the image over a black background (you can change the forum's skin to 'Cyborg' from your account's Settings), you will see this clearly. 🙂

  • Thanks @b77 got it

  • @vectoradmin Yes thank you that is useful

  • Problem has re-materialised.
    Initially I couldn't get anything to work. Expand was grayed out on the trace panel despite having 2000+ nodes.
    So I closed down vectorstyler and restarted and that got it working - expand was no longer greyed out
    Then I tried to ungroup..
    I have selected traced elements and carried out 'ungroup all' (** note for some reason the right button mouse context menu has stopped working for this .. I HAVE to use the menus now)

    SO I have a series of paths visible in the layers panel but I can't edit / open / select or use them

  • Ah OK.. so I have found that if I click on a layer I can then edit that element,
    Why on earth I can't select the same element in the document itself is beyond me - that is SO unintuitive.
    ALL I want to do (it feel likes 'ever') is double click on an element and edit it. This for whatever reason is not possible

  • @ambros Simple clicking (not double-clicking) on the round circle of any object in the Layers panel should select it.
    Or you can select it on the canvas by clicking it with the Transform tool (shortcut: V), assuming it's not grouped with some other object(s).

    If this doesn't help, please post the file if you can.

  • @b77 said in Can't get trace to work logically:

    @ambros Simple clicking (not double-clicking) on the round circle of any object in the Layers panel should select it.

    Thank you for the reply @b77 - Yes, I found that out (that selecting the layer/object in the layers panel enables it to be selected) But I have the options "Select Highlighted" and "Highlight Selected" both checked in the layers panel.
    I had thought that enabled the behaviour that I could just click on an element itself (within the artboard / canvas) and edit it.

    The issue with having to click on the layer - is that I have hundreds of paths (each on a separate layer) in the layers panel.. how on earth am i supposed to be able to find the one i need to click in order to be able to edit it ?

    By far the easiest and best way to select something in a document is to click on the item itself. the disconnect of looking at an object in front or you on the screen, and then have to scroll through a list of all objects in the document layers panel in order to edit it is bloody crazy to be honest.

    The shortcut 'V' enables the 'arrow tool' (I would personally call this the 'select' tool.
    If I click on an item in the document using that tool, I cannot select any of the items on the screen (except by using that self same tool to select the layer)

  • Ah HA!!

    If I click on this icon (members of composite select) and THEN use the arrow tool I CAN select the elements in the document :

    0_1638282079967_Screenshot 2021-11-30 142112.jpg

  • administrators

    @ambros That is not a good way to select objects. It selects shapes inside composite shapes (a bit complicated), but it will also select regular shapes.

    If you want to select inside a group, than the second icon (arrow with rounded rectangle) is better.

    But the Node tool (second in the toolbox), should select paths inside groups also.