EPS file reopens with missing text

  • Searched but haven't found this issue exactly. I've tried every permutation I can think of but when I reopen an EPS (created and saved in VS) the objects will import but not the text. The text areas are completely blank.

    On a MAC running Catalina.

    This is the test workflow:

    Created a file with basic shapes and a line of text.
    Saved as a VS file.
    Exported as an EPS file -- current art board, did not check vector text. As I understand it that should allow the text to be editable when the file is reopened.
    The file preview shows both the shapes and the text.
    Open the file and the only thing that imports are the shapes. Text is blank.

    Took the same file and exported with vector text checked off and the text does come back in as curves.

    Is there something that needs to be done in preferences or in the dialogue export box to make the text come back in without being converted to curves?

    Other than that I'm loving VS. Any help appreciated.

  • @black-hound

    looks like a bug to me

    on windows is even more worse
    no matter which variant I use
    no text appears in VS when i importing
    .eps files created this way
    Did export

    Selected objects, with and without vector text selected
    Current Artboard, with and without vector text selected

    the text appears, in other programs

    I posted it in the bug section

  • administrators

    @black-hound This looks like a bug. Text importing issues might have to do with the font type (OpenType, TrueType, Adobe are supported).
    What was the font name in this case?

  • @VectorStyler I tested with two font types:

    Times New Roman OTF and Zapfino TTF. Same result with both. Then I loaded the page with a mix of OTF and TTF from various foundries and none of the fonts imported back into VS from the EPS file.