VS loses paste function when attempting to paste vector from Illustrator CS2


  • Global Moderator

    This is related to the issue I had corresponded with you over email about @vectoradmin
    I've been using an old copy of Adobe CS2 on my windows laptop when I am traveling. Mostly to do the things lacking or that I don't know how to do in VS lol.
    So I noticed that when I go to copy a plain old vector shape from Illustrator CS2, when I return to VS, the paste buttons are grayed out.
    You can see in my video I attached, I first show that VS is functioning properly in that regard. I made a gray square and successfully copied and pasted it within VS. When I then went to Illustrator CS2 and copied a vector shape there, when I immediately returned to VS, I had no ability to paste.... also, the ability to paste in VS does not return. I have to restart VS and then it's restored. I can save the file where stuff will not paste, and when reopened I can paste like normal.
    so I wonder if this is the main issue I was dealing with? Is there something about the way Adobe handled vector objects in CS2 that is different than nowadays? Could this be related at all to the windows paste fix you were mentioning? Or did that already happen in beta 45?
    I'm going to do some more testing.
    UPDATE: I closed down VS and went back to Illustrator CS2. I copied the vector file before opening VS. Then after opening VS and even opening the file I had saved and closed prior, I was able to immediately paste it into VS successfully like normal. The ability to paste was normal as long as I did so within VS. Pasting from Affinity Designer worked as normal. Going back to Illustrator and copying something and returning to VS killed the paste function again.


  • Global Moderator

    This is the message I get in CS2 when I paste vectors from other more current apps like VS.

    0_1629003549104_053cedff-0851-46ad-aff1-db4fe5638c21-image.png


  • administrators

    @Boldline The pasting into VS bug on Windows is an open issue. It might be that some resources are exhausted after some time. Or it could be a CS2 issue.

    One thing to try to paste from VS to AI: in Preferences -> Performance disable the Copy as PDF and enable the Copy as SVG option. This is caused by VS creating the latest PDF version, which is very old by now, but CS2 seems to be older. I will also look into this if copying could create older PDF versions.


  • administrators

    @Boldline The exported (for clipboard) PDF version is now set to 1.6 (was 1.7 before). This should work with CS2. Let me know if there are still issues.