command+(+) / command+(-) Build 187, Mac, Big Sur 11.0.1 and Catalina 10.15.7

  • I just created a new user account at

    Big Sur 11.0.1
    MacBook (Retina, 12-inch, Early 2016)

    and reopened the new and the former copy of the build there: the same error. maybe it is something with the german keyboard map?

  • administrators

    German keyboard, that could be of course!
    Thanks, this should be easy to test.
    Will let you know when a fix is available.

  • thank you 👍🏻

  • @vectoradmin another report of a bug at the German version (at least at all my 3 macs listed above): the Zoom tool (Z) is only zooming in. I think with holding any of the common keys like at other apps (alt / command / shift / option) I would zoom out. This doesn't happen. Also the zoom at the magic mouse is not responding although I have tuned it on at the prefs.

    Maybe it is really at my computers. I have them setup quite identical. There could be interference with other global short cuts BUT: those shortcuts are identical with Affinity, Sketch, Figma … No problems there 😉

  • administrators

    Will look into this more.
    Meanwhile, the shortcut issues are solved and should be in the next release.

    When using the zoom tool, the common keys will not affect the zoom direction.
    Instead: dragging right/down direction zooms in, dragging left/up direction zooms out.
    To zoom with the magic mouse, hold Option key while scrolling.

    Will look into how to link these with system preferences (current they are not).

  • Thank you once again.

  • administrators

    The new build (188) should fix the shortcut issues with keyboard layouts.
    Let me know if this works now as expected on your machine also.

    The new build also contains improvements for the zoom tool. Click will zoom in, Option+Click zoom out.
    Open+drag can be used for "boxed" zoom in.

    Also there were some fixes around smart zoom. But this works (somewhat) different in VectorStyler.
    Smart zoom will iterate the zoom level over:

    • current artboard.
    • all artboards.
    • all elements of the current canvas
    • selected elements.

  • Cool thing. NOW it works as it should. Thank you.

    BUT there is now a new bug: 👉 See Recording

    This happens when I click on <control> and then on the artboard with the zoom-tool selected. The Zoom zooms in infinite. What you see on the recording is me hitting command-0 in between while the zoom kicks in again.

    Beside that: the commands work on all my devices as previously stated.

  • administrators

    Added this to the backlog.

  • administrators

    Additional fixes to the zoom tool are available with build 190.
    This should fix the broken zoom animation.