Making a symbol, unexpected results

  • I did group the part of the object & I wanted to define it as a symbol (Object-> Object role). I've got different objects in the symbol panel:


  • @VectorStyler Another bug ? I wanted to change the overall shape through the Shape editor and I got this:


  • & when I want to apply Transform:


  • @Pat Regarding the first issue:

    Did you drag-to-select over all three objects and their interpolated parts, to make sure all are selected before grouping?

    If I do that, here it works:

  • administrators

    @Pat Tried all these with the test file I have and cannot replicate here.

    Getting the 5 objects does look like the role was applied separately to those 5 objects, maybe there was some problem with the grouping?

  • @b77 @VectorStyler Thanks.
    I've always selected the whole object with the select&move tool and it worked so far.

    I tried to reproduce this problem. I selected and grouped and made sure everything was grouped. With the move tool, I can then duplicate it (Alt-drag) and move it.
    I activated 'Transform stroke' in the 'Object option' sub-menu, resize the whole object and made it a symbol (Object Role). It appears well in the symbol panel. I use it with the repeater function and the object ends up disappearing from the Symbol panel and from the large object I used to repeat it (Ctrl-R doesn't help).
    I will continue to test all these steps with a new file from the beginning.