Arranging Objects

Arranging Objects

The content of a canvas in a VectorStyler document, consists of a hierarchy of layers and objects. Objects may contain other objects, grouped and optionally clipped, to create complex design elements. The order in which objects are displayed on the canvas when overlapping (also called the stacking order), determines the visual appearance of the final artwork.

Objects may be transparent, or use various blending mode. Transparent objects are combined with objects drawn before (appearing earlier in the stacking order). Objects drawn under an object are also called the backdrop of the object.

When drawing new objects, they are typically placed on the top of the current layer (or isolated group), but it is also possible to draw at the bottom of the stack, behind an object, or inside a group of objects. The Select menu contains various drawing modes to place new objects at a certain location in the hierarchy.

  • Draw Normal - Objects are placed on the top of the current layer. The current layer can be selected in the Layers panel.
  • Draw Behind - Place new objects at the bottom of the object stack of the current layer.
  • Draw Before - Place new objects before the selected object.
  • Draw After - Place new objects after the selected objects.
  • Drawing Target - Select an object to be the target of drawing new objects. New objects will be drawn inside the target object.

The hierarchy and the stacking order of the objects can be changed using various commands and tools.

Grouping and Ungrouping

Object groups are created to keep multiple objects together as a single object. When multiple objects are grouped, the group will behave as a single object when selecting, transforming, applying effects or setting a transparency mask. Individual objects in a group can be selected (with the Pointer tool), by isolating the group for editing. A group can be isolated by double clicking on the group, or from the Layers panel menu.

  • To group the selected objects, select the Group command from the Edit menu, or press Command+G.
  • To ungroup the selected object groups, select the Ungroup command from the Edit menu, or press Shift+Command+G.

Changing the Object Order

The stacking order of the objects can be changed using the various arrangement commands from the Object - Arrange menu:

  • Inside Last - Place the selected objects into the last selected object. The default shortcut for this command is Option+Command+Right Arrow.
  • Outside Container - Place the selected objects outside from the containing objects. This command can be used to extract objects from groups. The default shortcut for this command is Option+Command+Left Arrow.
  • Bring to Front - Place the selected objects to the top of the stacking order.
  • Send to Back - Place the selected objects to the bottom of the stacking order.
  • Bring Forward - Move the selected objects one step towards the top of the stacking order.
  • Send Backward - Move the selected objects one step towards the bottom of the stacking order.
  • Send into Target - Place the selected objects into the drawing target object.
  • Place Before - Place the selected objects just under the last selected object in the stacking order.
  • Place After - Place the selected objects just above the last selected object in the stacking order.
  • Reorder - Rearranges stacking order the selected objects, to the same order as they were selected.
  • Reverse Order - Reverse the stacking order of the selected objects.
  • Random Order - Rearrange the stacking order of the selected objects to a random order.

The object hierarchy in the Layers panel shows the stacking order of the objects on the current canvas. The Layers panel can also be used to rearrange objects, by dragging and dropping objects in the list. For a detailed description of these options, see the Layers Panel section.

Placing Inside Other Objects

In VectorStyler, there are multiple commands and tools used to place objects inside other objects. When an object is placed inside another object, the container object shape will act as a clipping path of the object.

To place the selected object inside an object, select the objects and then select the target object. Then use the Inside Last command from the Object Arrange menu. An other mode to place objects inside an other object is to use the clipboard:

  • Select the objects and copy them to the clipboard using the Copy command from the Edit menu (or Command+C).
  • Select the target object.
  • Use the Paste Inside (Shift+Command+V) to paste the clipboard content inside the selected object.

The Layers panel can also be used to place objects inside an object. Select the objects in the layers panel, and drag and drop the selected objects on top of the target object in the panel.

Clipping Groups

When grouping objects, the created object group will have no initial shape. The objects inside the group are not clipped. In VectorStyler, it is possible to select a shape to an existing group of objects, in order to clip the group content into that shape. The group may or may not already have a clipping shape. To change the clipping shape of a group, use one of the following steps:

  • An object shape, including groups, can be changed by copying and pasting only the shape. Select the object whose shape will be used and select the Copy Shape command from the Edit menu. Then select the object group (or any other object), and select the Paste Shape command from the Edit menu. Use the shape picker tool to pick and place shapes from one object to an other (including groups).
  • An object shape, including groups, can be changed from the Shape panel. If the required shape is not already saved, select the object with the shape, and create a new shape style or preset using the Style field of the Shape panel. Then select the object group, and select the shape style or preset from the shape panel.